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1. Import danych do analizy 

 

 

Rys. 1 Okno programu wraz z przykładowymi arkuszami danych. 

 

Obsługa danych w programie Statistica odbywa się przy pomocy tzw. arkuszy. 

Na rys. 1 pokazano przykładowe arkusze danych Example1 i Example2 w oknie 

programu. Dane do arkuszy mogą być wpisywane ręcznie, wklejane poprzez scho-

wek, lub importowane z plików.  

Najczęściej dane podlegające na Pracowni obróbce statystycznej tworzone są 

przez oprogramowanie wykorzystywane w poszczególnych ćwiczeniach i są zapisa-

ne w plikach ASCII z rozszerzeniem DAT lub TXT. W celu zaimportowania pliku z 

danymi należy zastosować opcję File → Open… . W otwieranym w ten sposób oknie 

dialogowym definiujemy lokalizację, w której zapisano plik z danymi a następnie w 

okienku dialogowym Pliki typu: zmieniamy filtr wyświetlanych plików na All files 

(*.*). Wskazujemy żądany plik i używamy klawisza Otwórz. W pojawiającym się 

okienku dialogowym zatytułowanym Importing file muszą być zaznaczone opcje 

Import as Spreadsheet, oraz Delimited. 

 Kolejne okno dialogowe importu danych (rys. 2) zawiera cały szereg opcji, ale 

nie wymaga zwykle wprowadzania żadnych zmian. Problemy mogą pojawić się wte-

dy, kiedy oprogramowanie tworzące dane stosuje inne separatory dziesiętne niż zde-

finiowane w systemie operacyjnym. Można to łatwo stwierdzić, ponieważ w dolnej 

części okna pokazano, w jaki sposób są rozpoznawane importowane dane. Jeśli 

część całkowita w liczbach zmiennoprzecinkowych odseparowana jest od części 

ułamkowej kropką, to należy kliknąć klawisz Reset, a następnie wybrać opcję Deci-
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mal separator character i wpisać w okienku edycyjnym kropkę zamiast przecinka. 

Należy pamiętać aby po każdej zmianie wcisnąć przycisk Refresh View. 

 

 

 

Rys. 2 Okno dialogowe importu danych: a) prawidłowy import danych, b) nieprawidłowy import da-

nych. 
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 Aby sprawdzić czy import danych jest prawidłowy, należy zaznaczyć kolumnę 

z danymi (rys. 2). W oknie Data type powinna wyświetlać się opcja Double. W przy-

padku gdy pojawi się opcja Text/Data/itp. należy sprawdzić czy na pewno zazna-

czone są prawidłowe opcje importu i ponownie wcisnąć przycisk Refresh View. 

 W przypadku, gdyby mimo wszystko dane nie zostały zaimportowane prawi-

dłowo należy je zaznaczyć i przy pomocy opcji Edit → Replace… zamienić wszyst-

kie kropki na przecinki tak jak to się robi w edytorach tekstu. 

 

 

2. Podstawowe operacje wykonywane w arkuszu danych 

Operacje na arkuszach danych w programie Statistica odbywają się na podob-

nych zasadach jak w typowych arkuszach kalkulacyjnych (np. MS Excel). 

Aby zaznaczyć całą kolumnę (wiersz) należy kliknąć szary klawisz 

z oznaczeniem kolumny (numerem wiersza). Przykładowo, aby zaznaczyć trzecią 

kolumnę od lewej w arkuszu pokazanym na rys. 1, należy kliknąć klawisz oznaczony 

3 Var3. Liczba 3 oznacza numer kolumny, natomiast Var 3 jest nazwą zmiennej re-

prezentowanej w kolumnie.  

a) Tworzenie pustego arkusza danych. W trakcie tworzenia nowego arkusza da-

nych (File → New…, zakładka Spreadsheet) należy zdefiniować liczbę kolumn 

(Number of variables:) oraz liczbę wierszy (Number of cases:). Pozostałe opcje 

zwykle pozostają bez zmian. Utworzony arkusz posiada wybraną liczbę kolumn 

i wierszy i są one zaznaczone kolorem białym. Pozostałe kolumny (na prawo) 

i pozostałe wiersze (poniżej) zaznaczone są na szaro i dopóki nie przedefiniujemy 

liczby zmiennych i przypadków nie można do nich wprowadzać danych. 

b) Zmiana zawartości komórki. Po kliknięciu na komórce należy wprowadzić nową 

wartość. Akceptacja zmiany następuje po naciśnięciu klawisza ENTER lub po przej-

ściu do innej komórki. 

c) Usunięcie zawartości komórki. Po zaznaczeniu komórki używamy klawisza DE-

LETE.  

d) Dodawanie nowej kolumny/wiersza na końcu arkusza. Należy wykonać po-

dwójne kliknięcie na szarym obszarze arkusza (poza aktywnym obszarem). W poja-

wiającym się okienku dialogowym Add cases and/or variables wpisuje się liczbę 

nowych kolumn i/lub wierszy. Pola edycyjne okna dialogowego są już wypełnione 

liczbami. Zależą one od pozycji, w której nastąpiło podwójne kliknięcie. Przykładowo, 

jeśli chcemy w pokazanym na rys. 1 arkuszu wprowadzić dwie nowe kolumny i trzy 

nowe wiersze, to klikamy podwójnie dwie pozycje na prawo i trzy pozycje w dół licząc 

od skrajnej lewej i najniższej aktywnej (białej) komórki arkusza. 
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e) Dodawanie nowej kolumny/wiersza w dowolnym miejscu arkusza. Opcja In-

sert pozwala na wstawienie nowych wierszy i kolumn w dowolnym miejscu arkusza. 

Należy wybrać opcję Add variables… lub Add cases… w zależności od potrzeb. W 

pojawiającym się oknie dialogowym wypełniamy odpowiednio pola How many:, 

After: i Name: w przypadku wstawiania nowych kolumn, oraz pola How many: i In-

sert after case: w przypadku wstawiania nowych wierszy.   

f) Usuwanie fragmentów arkusza. Istnieje możliwość usunięcia całych kolumn i/lub 

wierszy. Aby to zrobić należy zaznaczyć fragment do usunięcia i wybrać jedną z opcji 

Edit → Delete → Variables… lub Edit → Delete → Cases… . 

g) Zmiana właściwości zmiennych (kolumn). Dodatkowe opcje ustawień 

właściwości zmiennych (kolumn) arkusza (np. nazwa, typ, format) można uzyskać po 

dwukrotnym kliknięciu na nagłówku kolumny. Najważniejsze opcje jakie daje 

wyświetlane w ten sposób okno dialogowe (rys.3), to zmiana nazwy zmiennej 

i obliczanie statystyk kolumny. Nazwa zmiennej w programie Statistica jest bardzo 

istotna, ponieważ przy jej pomocy odwołujemy się do zmiennej we wszelkiego 

rodzaju operacjach, np. podczas przeliczania danych, czy tworzenia wykresów. 

Klawisz Values/Stats… pozwala na szybkie obliczanie wartości średniej, odchylenia 

standardowego i liczby przypadków z danych znajdujących się w kolumnie.  

 

 

Rys. 3 Okno dialogowe właściwości zmiennych. 

 

3. Przeliczanie danych w arkuszu 

Istnieje kilka możliwości wykonywania operacji arytmetycznych na danych zapi-

sanych w arkuszu. Zwykle efekt takich obliczeń umieszczany jest w nowej kolumnie. 

Jedną z możliwości jest wykorzystanie okna definiującego właściwości kolumny 

(rys. 3). Dostęp do tego okna uzyskuje się poprzez podwójne kliknięcie na nagłówku 
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kolumny. W polu Long name (label or formula with Functions): należy wprowadzić 

żądaną formułę. Przykładowo, jeżeli w kolumnie Var3 chcemy umieścić wynik doda-

wania w kolejnych wierszach wartości z kolumn Var1 i Var2, to w w/w pole wprowa-

dzimy: „=Var1+Var2”. Klawisz Functions umieszczony nad polem edycyjnym umoż-

liwia wybieranie i wprowadzanie funkcji zaimplementowanych w programie.  

Podobnie działa opcja Data → Batch Transformation Formulas…, która 

otwiera okno dialogowe pokazane na rys. 4. Pole edycyjne tego okna daje możliwość 

wprowadzania bardzo skomplikowanych formuł z zastosowaniem funkcji dostępnych 

w programie. Istnieje możliwość wykonywania operacji, których wyniki będą umiesz-

czone w kilku kolumnach zmiennych równocześnie. W przykładzie pokazanym na 

rys. 4 w kolumnie zmiennych o nazwie Var3 umieszczone będą wyniki dodawania 

elementów znajdujących się w kolumnach Var1 oraz Var2. W kolumnie Var4 zostaną 

obliczone wyniki mnożenia elementów kolumny zmiennych Var1 przez pierwiastek 

kwadratowy z elementów zmiennych Var2. 

 

 

Rys. 4 Okno dialogowe przeliczania zmiennych. 

 

W odróżnieniu do typowych arkuszy kalkulacyjnych w Statistica dane mogą nie 

być przeliczane automatycznie. Oznacza to, że jeśli zmianie ulegną dane na podsta-

wie, których wykonano obliczenia, to ich wyniki nie muszą być automatycznie aktua-

lizowane. Aktualizacja danych jest możliwa tylko w przypadku wprowadzania formuł 

w oknie właściwości kolumn (rys. 3), wymusza się ją opcją Data → Recalculate 

Spreadsheet formulas… . Arkusze będą przeliczane automatycznie, jeżeli w poja-

wiającym się oknie włączymy opcję Auto-recalculate when the data change. Au-

tomatyczna aktualizacja w przypadku obliczeń wykonanych opcją Data → Batch 

Transformation Formulas… nie jest możliwa. W takim przypadku należy ponownie 

użyć tej opcji w celu wykonania obliczeń na aktualnych danych. 
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4. Statystyka opisowa 

 Statistica oferuje bardzo wygodne i szybkie sposoby na uzyskiwanie informa-

cji o statystykach zmiennych zawartych w kolumnach. Istnieją trzy sposoby na obli-

czanie statystyk. Dają one wyniki o różnym stopniu złożoności i w nieco innych for-

mach, dlatego nie mogą być stosowane zamiennie. 

Sposób 1: Kliknąć dwukrotnie nagłówek kolumny, co spowoduje wyświetlenie 

okna dialogowego pokazanego na rys. 3. Klawisz Values/Stats… pozwala na 

uzyskanie informacji o liczebności przypadków, średniej i odczyleniu standardowym 

(rys. 5). Klawisz  daje możliwość skopiowania statystyk do schowka.  

Sposób 2: Zaznaczamy kolumny zmiennych, których statystyki chcemy 

obliczyć. Prawym klawiszem myszy klikamy w obrębie zaznaczonych kolumn i z 

pojawiajcego się menu kontekstowego (rys. 6) wybieramy opcję Statistics of Block 

Data → Block Columns a następnie wybieramy statystyki, które chcemy uzyskać, 

np. All. Obliczone statystyki pojawiają się w nowo utworzonym arkuszu. Metodą tą 

można również obliczać statystyki dowolnego zaznaczonego fragmentu arkusza. 

 

 

Rys. 5 Okno dialogowe wyświetlające statystyki kolumny zmiennych. 

 

 

Rys. 6 Obliczanie statystyk opisowych dla kolumn zmiennych. 
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Sposób 3: Wybieramy opcję Statistics → Basic Statistics/Tables. 

W pojawiającym się oknie dialogowym wybieramy opcję Descriptive statistics 

i potwierdzamy wybór klawiszem OK. W następnym oknie dialogowym wybieramy 

klawisz Sumary: Statistics lub klawisz Summary. Jeśli przed uruchomieniem oma-

wianej procedury zaznaczone były kolumny zmiennych, to obliczenia dotyczyć będą 

zaznaczonych kolumn. W przeciwnym razie pojawi się dodatkowe okno, w którym 

trzeba określić, dla których zmiennych mają zostać wykonane obliczenia. Wyniki po-

jawiają się w nowym arkuszu. 

 

5. Histogram 

Aby utworzyć histogram danych zapisanych w kolumnach arkusza należy wy-

brać polecenie Graphs → Histograms…. Po wybraniu tego polecenia pojawia się 

okno dialogowe 2D Histograms (rys. 7) z poleceniem Variables, którym wywołuje-

my okno Select Variables for Histogram (rys. 8). Należy w nim wybrać kolumny 

z danymi, dla których chcemy stworzyć histogram. 

 

 

Rys. 7 Okno dialogowe 2D Histograms. 

 

 

Rys. 8 Okno Select Variables for Histogram. 
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Okno 2D Histograms zawiera zakładkę Advanced (rys. 9), która posiada opcje 

edycji histogramu oraz dopasowania do niego kilku rodzajów rozkładów. 

 

 

Rys. 9 Zakładka Advanced okna 2D Histograms.  

 

Włączenie opcji Boundaries oraz naciśnięcie klawisza Specify Boundaries 

wywołuje okno (rys. 10) umożliwiające ustawienie zakresu wyświetlanych na wykre-

sie wartości oraz szerokości słupka na histogramie (Interval Step). Określone w tym 

oknie zakresy minimum i maksimum nie definiują zakresu, który brany jest pod uwa-

gę w procedurze dopasowania do histogramu rozkładu modelowego. 

 

 

Rys. 10 Okno edycji zakresu wyświetlanych na wykresie wartości oraz szerokości słupka w histogra-

mie. 

Wybór dopasowania 
rozkładu do histogramu 

Panel parametrów 
statystycznych 
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Zaznaczona w oknie 2D Histograms opcja Descriptive statistics spowoduje 

pojawienie się na wykresie parametrów statystycznych wyznaczonych na podstawie 

danych. Po naciśnięciu przycisku OK pojawi się wykres – histogram (rys. 11): 

 

 

Rys. 11 Przykładowe okno z histogramem. 

 Edycja wszystkich elementów histogramu (np. opisów, osi, tytułu itd.) odbywa 

się poprzez dwukrotne ich kliknięcie.  

 Istnieje możliwość wyeliminowania z analizy niektórych danych (np. powsta-

łych na skutek błędów pomiarowych). Usuwanie zbędnych danych na histogramie 

możliwe jest poprzez wykorzystanie funkcji Brushing, którą wywołujemy poprzez 

naprowadzenie kursora myszki na wykres, kliknięcie prawym przyciskiem i wybranie 

opcji Show Brushing (rys. 12). 

 

 

Rys. 12 Wywoływanie opcji Show Brushing. 

Parametry sta-
tystyczne  
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W celu usunięcia zbędnych danych zaznaczamy je stosując lewy przycisk 

myszki. Zaznaczone dane zostaną wyróżnione, a ich usunięcie realizujemy klikając 

prawy przycisk myszki i wybierając opcję Brushing Off (rys.13). 

 

 

Rys. 13 Usuwanie danych z histogramu. 

 

6. Tworzenie wykresów 

Wykres w najprostszym przypadku, to zbiór wybranych punktów płaszczyzny, 

przy czym współrzędna zależna punktu (Y) jest funkcją współrzędnej niezależnej (X). 

Zanim wykres zostanie utworzony należy ustalić, która kolumna arkusza jest kolum-

ną zmiennych niezależnych, a która kolumną zmiennych zależnych. Wykresy tworzy 

się poleceniem Graphs → Scatterplots… (rys. 14), które otwiera okienko dialogowe 

2D Scatterplots pokazane na rys. 15. 

 

 

Rys. 14 Tworzenie wykresu. 
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Rys. 15 Okno dialogowe 2D Scatterplots. 

 

 

Rys. 16 Okno wyboru zmiennej niezależnej i zależnej dla wykresu. 

 

Wybór kolumny zmiennej niezależnej (X) oraz zmiennej zależnej (Y) odbywa 

się poprzez kliknięcie klawisza Variables. Pojawia się okno wyboru kolumn dla po-

szczególnych zmiennych (rys. 16). W oknie Select Variables for Scatterplot wybie-

ramy kliknięciem właściwą kolumnę dla zmiennej X oraz Y. Wybór zatwierdzamy 

przyciskiem OK. Przykładowy wykres punktowy pokazano na rys. 17. 
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Rys. 17 Przykładowy wykres punktowy programu Statistica. 

 

Formatowanie wykresu to wszelkie czynności mające na celu ustalenie wła-

ściwości poszczególnych elementów wykresu. Aby zmienić właściwości wybranego 

elementu należy na nim kliknąć dwukrotnie, a w oknie dialogowym, które się wów-

czas pojawi, należy wybrać odpowiednie opcje. Przykładowo dwukrotne kliknięcie na 

tekście Var1 poniżej poziomej osi (rys. 17) pozwoli na zmianę opisu osi X. Podob-

nie, dwukrotne kliknięcie na tytule wykresu spowoduje wyświetlenie okna dialogowe-

go, w którym można modyfikować treść tytułu i jego wygląd. Dostęp do wszystkich 

opcji dotyczących formatowania wykresu uzyskujemy poprzez kliknięcie prawego 

przycisku myszki na wykresie i wybraniu opcji Graph Options.  

 

 

Rys. 18 Okno dialogowe Graph Options. 
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Skalowanie osi X bądź Y można przeprowadzić wybierając opcję Scalling 

w oknie Graph Options. Możliwość ręcznego wprowadzenia wartości minimalnych 

i maksymalnych na osiach odbywa się poprzez wybór opcji Mode: Manual oraz wpi-

sanie żądanych wartości. 

Aby odczytać współrzędne punktu na wykresie klikamy prawym przyciskiem 

myszy na dany punkt. Z dostępnych opcji wybieramy Annotate Points…. Na wykre-

sie pojawia się wówczas okienko, w którym podane są wartości X i Y współrzędnych 

punktu (rys. 19) 

 

          

Rys. 19 Odczyt współrzędnych punktu na wykresie. 

 

W przypadku konieczności wykonania operacji jedynie na części danych pomia-

rowych można usunąć z wykresu te dane, które nie są potrzebne. Można to osiągnąć 

stosując funkcję Brushing, którą wywołujemy poprzez naprowadzenie kursora 

myszki na wykres, kliknięcie prawego przycisku i wybranie opcji Show Brushing 

(rys. 20). 

 

 

Rys. 20 Wywołanie opcji Show Brushing. 

 

Aby usunąć zbędne dane klikamy lewym przyciskiem myszki na wybrany punkt 

na wykresie i zaznaczamy go. Usuwanie wielu punktów danych realizujemy poprzez 

kliknięcie lewym przyciskiem z wciśniętym równocześnie klawiszem CTRL. Zazna-
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czone dane zostaną podświetlone kolorem czarnym (rys. 21). Usunięcie punktów 

realizujemy klikając prawym przyciskiem myszki i wybierając opcję Brushing Off. 

 

 

Rys. 21 Usuwanie danych z wykresu. 

  

 

7. Tworzenie wykresu na podstawie danych zawartych w różnych 

arkuszach 

 Stworzenie wykresu prezentującego dane z dwóch różnych arkuszy możliwe 

jest tylko poprzez umieszczenie ich w jednym wspólnym arkuszu. Aby prawidłowo 

identyfikować kolumny danych i nie mylić ich między sobą we wspólnym arkuszu ko-

nieczna jest zamiana nazw kolumn tak, aby się nie powtarzały. Nazwę kolumny 

zmieniamy klikając dwukrotnie lewym przyciskiem myszki na nagłówek kolumny. Po-

jawia się wówczas okno dialogowe, w którym m.in. istnieje możliwość zmiany nazw 

kolumny zmiennych (rys. 22). 

 

 

Rys. 22 Zmiana nazwy kolumny. 

Pole zmiany 
nazwy ko-
lumny 
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Po zamianie nazw kolumn tworzymy wspólny arkusz dla wszystkich danych, na 

podstawie, których chcemy zrobić wykres. Aby utworzyć wspólny arkusz wybieramy 

opcję Data → Merge… (rys. 23). Wywołanie powyższej opcji spowoduje pojawienie 

się okna Merge Options (rys. 24).  

 

 

 

Rys. 23 Opcja łączenia arkuszy danych. 

 

 

 

Rys. 24 Okno Merge Options. 

 

Wybór arkuszy danych do stworzenia wspólnego arkusza odbywa się poprzez 

użycie klawiszy  oraz . Wybrane nazwy arkuszy danych poja-

wiają się po prawej stronie klawiszy. Zatwierdzenie przyciskiem OK powoduje po-
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wstanie nowego arkusza zawierającego dane z wybranych arkuszy. Aby utworzyć 

wspólny wykres dla kilku zależności należy z menu głównego wybrać polecenie Gra-

phs → Scatterplots… (rys. 25). Wybranie powyższej opcji powoduje pojawienie się 

okna 2D Scatterplots (rys. 26).  

 

 

 

Rys. 25 Tworzenie wykresu. 

 

 

 

Rys. 26 Okno dialogowe 2D Scatterplots. 

 

Stworzenie wykresu dla kilku zmiennych Y wymaga zaznaczenia w polu Graph 

type: opcji Multiple. Wybór kolumny zmiennej niezależnej (X) oraz zmiennych za-

leżnych (Y) odbywa się poprzez kliknięcie klawisza Variables w oknie 2D Scatter-

plots. Pojawia się okno wyboru kolumn dla poszczególnych zmiennych gdzie wybie-

Opcja wyboru 
typu wykresu 
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ramy właściwą kolumnę dla zmiennej X oraz właściwe kolumny dla zmiennej Y. Wy-

boru kilku kolumn dokonujemy używając równocześnie myszy i klawiszy Shift lub 

Ctrl. Wybór zatwierdzamy przyciskiem OK. Przykładowy wykres punktowy dwóch 

zależności pokazano na rys. 27. 

 

 

Rys. 27 Przykładowy wykres punktowy wielu (dwóch) zmiennych. 

 

 

8. Całkowanie 

Całkowanie wykresu funkcji to obliczanie pola powierzchni pod wykresem tej 

funkcji w określonych granicach. Aby oznaczyć granice całkowania należy na wykre-

sie wybrać punkty określające dolną i górną granicę. Można to zrobić wykorzystując 

funkcję Brushing. Włączamy ją klikając na wykresie prawym przyciskiem myszy i 

wybierając opcję Show Brushing. Lewym klawiszem myszki zaznaczamy żądany 

punkt na wykresie (punkt podświetlany jest na czarno). Następnie prawym przyci-

skiem myszy wybieramy opcję Brushing Mark → Mark (rys. 28). W efekcie punkt 

zostaje zaznaczony na wykresie, ale również w arkuszu danych przy pomocy czer-

wonego wykrzyknika (rys. 29).  

 



Pracownia Biofizyczna, Zakład Biofizyki CMUJ  

Instrukcja programu Statistica  19 

 

Rys. 28 Zaznaczanie granic całkowania. 

 

 

 
Rys. 29 Oznaczenie wyróżnionego na wykresie punktu w arkuszu danych. 

 

W najprostszym przypadku całkowanie fragmentu wykresu można przybliżyć 

procedurą polegającą na zsumowaniu wartości punktów zmiennej zależnej (Y) w za-

danym przedziale oraz pomnożeniu ich przez iloraz szerokości przedziału całkowa-

nia i liczby punktów w danym zakresie. Wszystkie parametry potrzebne do obliczenia 

pola powierzchni pod wykresem można wyznaczyć przy pomocy statystyk opiso-

wych. W pierwszej kolejności zaznaczamy w arkuszu danych wiersze pomiędzy 

wierszami zaznaczonymi wcześniej opisaną metodą (górna i dolna granica całkowa-

nia oznaczone są wykrzyknikami) (rys. 30). Następnie z paska zadań wybieramy op-

cję Statistics → Statistics of Block Data → Block Columns → All (rys. 31). Poja-

wia się arkusz z wszystkimi danymi potrzebnymi do wyznaczenia wartości pola po-

wierzchni pod zadaną częścią wykresu (rys. 32).  
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Rys. 30 Zaznaczanie zmiennych do całkowania w arkuszu danych. 

 

 

 

 

Rys. 31 Wybór opcji statystyki bloku danych w zadanym przedziale. 

 

Dolna granica cał-
kowania 

Górna granica cał-
kowania 
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Rys. 32 Arkusz z danym potrzebnymi do obliczenia pola powierzchni pod wykresem. 

 

Przykładowo, jeśli zmienną niezależną (X) oznaczono w arkuszu na rys. 29 jako 

Var1, a zmienną Y jako Var2 to pole powierzchni Ps pod zaznaczonym fragmentem 

wykresu jest równe:  

)1(_

))1()1((
)2(

VarNValid

VarMINVarMAX
VarSUMPs

−
=  

 

9. Fitowanie standardowych modeli do danych doświadczalnych 

 Program Statistica daje możliwość równoczesnego rysowania wykresów 

i fitowania do danych doświadczalnych prostych modeli matematycznych. Omawiana 

metoda nie pozwala na obliczanie błędów współczynników dopasowania krzywych 

modelowych. W przypadku, kiedy konieczne jest obliczanie takich błędów należy się 

posłużyć metodą opisaną w następnym punkcie instrukcji. Po wybraniu opcji Gra-

phs → Scatterplots… (albo Graphs → 2D Graphs  → Scatterplots… ) w oknie 

dialogowym wybieramy zakładkę Advanced (rys. 33). 

 

 

Rys. 33 Okno dialogowe 2D Scatterplots, zakładka Advanced. 
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W pierwszej kolejności należy zdefiniować kolumnę zmiennych zależnych 

i niezależnych, dla których będzie sporządzony wykres i dla których zostanie dopa-

sowana krzywa modelowa. Robi się to przy pomocy klawisza Variables. W panelu 

Fit wybieramy rodzaj dopasowywanego modelu matematycznego. W ramach ćwi-

czeń na pracowni będziemy wybierali jedynie trzy możliwości: Linear, Logarithmic i 

Exponential w zależności od potrzeb, czyli funkcję odpowiednio postaci: Y=B+A·x, 

Y=A+B·log(x) oraz Y=A·eB·x. W panelu Statistics należy zaznaczyć te parametry 

dopasowania, które mają zostać włączone do wykresu. Klawisz OK kończy proces 

fitowania i kreślenia wykresu. Przykład wykresu zmiennej Var2, jako funkcji Var1 do-

pasowanej linia prostą przedstawia rys. 34. W lewym dolnym rogu wykresu pokazano 

parametry dopasowania. Równanie dopasowanej prostej znajduje się również w tytu-

le wykresu.  

W przypadku, kiedy istnieje konieczność dopasowania modelu matematyczne-

go jedynie w pewnym zakresie zmiennej niezależnej postępujemy tak samo jak wy-

żej, tzn. tworzymy wykres z dopasowaniem w całym zakresie, a następnie ograni-

czamy zakres dopasowania. Żeby ograniczyć zakres fitowania należy na gotowym 

wykresie kliknąć dwukrotnie dopasowaną krzywą. Pojawi się wtedy okno dialogowe 

Graph Options otwarte się na zakładce Fitting, jak to pokazano na rys. 35. Warto-

ścią domyślną w polu wyboru Range: jest Full Range. Wartość tą należy zmienić na 

Axis Range, żeby podczas dopasowywania brany był pod uwagę jedynie zakres 

określony osią X, albo też opcję Custom Range. W przypadku tej ostatniej opcji na-

leży zdefiniować początek i koniec zakresu dopasowania w polach edycyjnych Min: i 

Max:. 

 

 

Rys. 34 Przykładowy wykres z dopasowanym modelem liniowym. 
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Rys. 35 Okno opcji wykresu otwarte na zakładce Fitting. Wybrano opcję Range, pozwalającą przede-

finiować zakres zmiennej niezależnej, do którego ma się odnosić dopasowanie krzywą modelową.  

 

 

10. Fitowanie niestandardowych modeli do danych 

W przypadku konieczności dopasowania do danych eksperymentalnych dowol-

nej funkcji stosujemy opcję Statistics → Advanced Linear/Nonlinear Models → 

Nonlinear Estimation (rys. 36). W pojawiającym się okienku dialogowym (rys. 37) 

wybieramy opcję User-specified regresion, last squares I potwierdzamy wybór 

klawiszem OK. W kolejnym oknie dialogowym wybieramy klawisz Func-

tion to be estimated.  

 

 

Rys. 36 Opcja służąca do fitowania niestandardowych modeli do danych doświadczalnych. 
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Rys. 37 Okienko wyboru metody dopasowania danych. 

 

Okienko dialogowe pokazane na rys. 38 pozwala na zdefiniowanie postaci 

funkcji, która będzie dopasowana do danych. Opis w dolnej części okna podaje przy-

kłady, w jaki sposób można to zrobić. W definicji funkcji można się posługiwać na-

zwami zmiennych, operatorami i funkcjami dostępnymi w programie. Ciągi znaków 

nierozpoznane przez program, jako nazwa operatora, funkcji lub zmiennej traktowa-

ne są, jako parametry definiowanego modelu. W przykładzie pokazanym na rys. 38 

dopasowana będzie funkcja postaci xCeBAy −+= , gdzie zmienna v2 (kolumna 

Var2) pełni rolę zmiennej zależnej, a v1 (kolumna Var1) pełni rolę zmiennej niezależ-

nej. UWAGA: Należy pamiętać aby przy wpisywaniu funkcji używać krótkiej nazwy 

kolumny ‘v1’ zamiast długiej nazwy ‘Var1’ widocznej w nagłówku kolumny. 

 

 

Rys. 38 Okno definicji funkcji dopasowania. 
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Po zdefiniowaniu postaci dopasowywanej funkcji wybieramy klawisz OK, co 

powoduje powrót do okienka User-Specified Regresion, Last Squares. Do dalsze-

go etapu procedury przechodzimy klawiszem OK. 

Procedura dopasowania odbywa się metodą minimalizacji. Komputer próbuje 

znaleźć wartości parametrów dopasowania wychodząc z pewnych początkowych 

wartości parametrów. Wartości te zmieniane są z pewnym zadanym krokiem. 

W oknie dialogowym, które się pojawiło wybieramy klawisz OK. W przypadku, kiedy 

domyślne wartości parametrów i wartości kroków były dobrane prawidłowo program 

wykona dopasowanie. W przeciwnym razie pojawią się komunikaty błędów, np. „Pre-

dictors are probably very redundand; estimates suspect”. W takim przypadku zamy-

kamy komunikat błędu, a w okienku dialogowym wybieramy zakładkę Advanced jak 

pokazano na rys. 39. Znajduje się tam klawisz Start values, który daje możliwość 

przedefiniowania wartości początkowych wszystkich parametrów dopasowania (rys. 

40). Dobór parametrów początkowych nie jest prosty, należy tu wstawić wartości 

zbliżone do takich, jakie spodziewamy się uzyskać, a to wymaga pewnego doświad-

czenia. Na początek można spróbować wyzerować wartości początkowe wszystkich 

parametrów. Innym rozwiązaniem jest dopasowanie danych przy pomocy prostsze-

go, standardowego modelu, a następnie posłużenie się parametrami, które są efek-

tem działania takiego uproszczonego modelu.  

Jeżeli procedura minimalizacji powiedzie się, to na ekranie zostanie wyświetlo-

ne okno dialogowe z wynikami (rys. 41). Klawisz Sumary wyświetla arkusz w wyni-

kami dopasowania (rys. 42) natomiast klawisz Fitted 2D function & observed vals 

tworzy wykres danych z dopasowaną funkcją.  

 

 

Rys. 39 Zaawansowane opcje dopasowania. 
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Rys. 40 Okno wyboru początkowych wartości parametrów dopasowania.  

 

 

Rys. 41 Okno dialogowe pozwalające na wyświetlanie wyników dopasowania. 

 

 

 

Rys. 42. Arkusz z wynikami dopasowania.  
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11. Umieszczanie wykresów w pliku LibreOffice Writer 

Aby umieścić wykonany wykres w sprawozdaniu, klikamy prawym przyciskiem myszy 

w obszarze wykresu i wybieramy opcję Copy Graph (można też użyć skrótu klawi-

szowego Ctrl+C, rys. 43). W oknie programu LibreOffice ustawiamy kursor w miej-

scu, gdzie ma być wklejony wykres i wybrać opcję Edit → Paste Special… (można 

również użyć kombinacji klawiszy: Ctrl+Shift+V). W oknie, które się pojawi (rys. 44), 

wybieramy opcję GDI metafile i klikamy przycisk OK. 

 

 

Rys. 43. Opcja służąca do kopiowania wykresu. 

 

 

 

Rys. 44. Okno wyboru opcji wklejania. 


